Wie zijn er volgende maand jarig. Hoe sorteer je op verjaardag in Excel

Door: HR-ICT   |   Publicatiedatum: 20 maart 2018

Het samenstellen van een lijst met verjaardagen is voor sommigen een maandelijks terugkerende activiteit. De vraag hierbij is: Hoe sorteer je op verjaardagen in Excel. In deze blog leg ik uit hoe je met Excel in een handomdraai een op verjaardag gesorteerd overzicht samenstelt.
Hiervoor moet je de geboortedatum sorteren op maand.

Wat je nodig hebt is een bestand met de namen en geboortedatums.

De vragen die eigenlijk beantwoord moeten worden zijn:

Hoe sorteer je op volgorde van maand en dag.

Een datum kan standaard niet worden gesorteerd op volgorde van maand. Daarvoor moet een datum eerst worden omgezet naar een tekst met het formaat maand-dag-jaar (MM-DD-JJJJ). De maand staat dan vooraan en is daarmee bepalend voor de volgorde.

sorteren op maand

Voor dit omzetten van de datum gebruiken we de Excel functie TEKST. Deze functie komt in een nieuwe lege kolom te staan.
In bovenstaand voorbeeld is deze functie toegepast als : =TEKST(A2;”mm-dd-jjjj”).
In dit voorbeeld is A2 de cel met de geboortedatum en “mm-dd-jjjj” het nieuwe datum formaat. Als nu sorteert op de nieuwe kolom dan wordt de volgorde maand-dag-jaar.

Hoe bepaal je de verjaardagsdatum in Excel.

Voeg voor de verjaardagsdatum nog een extra kolom toe en pas voor deze kolom de cel eigenschappen aan naar ‘Lange Datumnotatie’.
De verjaardagsdatum kan je bepalen met de Excel functie DATUM.
=DATUM(“2017”;MAAND(A2);DAG(A2))
Hierbij is 2017 het jaar waarvoor de lijst met verjaardagen moet worden opgesteld en A2 de cel met de geboortedatum.

Verjaardagen sorteren op maand

Sorteer nu de aangepaste datum in kolom B op alfabetische volgorde en de lijst met verjaardagen is gereed.

cursus draaitabellen

Selecteren verjaardagen in de volgende maand.

Eventueel kan je met het filter een selectie maken van een specifieke maand.

  • Klik daarvoor op het selectiedriehoekje van het filter in kolom B.
  • Selecteer daarna achtereenvolgens “tekstfilters” en “begint met”.
  • Tik tenslotte het maandnummer in bij voorbeeld 05 voor mei of 10 voor oktober.

filteren op een maandnummer in Excel

 

Deze blog heb ik opgesteld naar aanleiding van meerdere vragen over het sorteren op maand tijdens de cursus Excel

Heel veel succes er mee!

Heeft dit artikel je geholpen? Deel deze pagina dan via social media: de kans is groot dat andere mensen er ook wat aan hebben. Alvast bedankt!

Hans van Dijk – HR-ICT opleidingen

HR-ICT opleidingen organiseert praktijkgerichte Excel cursussen in Rotterdam, Alphen aan den Rijn en Leiden. HR-ICT opleidingen kan ook worden ingeschakeld voor het verzorgen van een incompany Excel training bij u op kantoor.

Misschien ook interessant om te lezen
Excel voorwaardelijke opmaak – hele rijen opmaken
Samenstellen van een top 3 of top 10 van de waarden in een draaitabel
Veranderen datum formaat in MS-Word mailing
Flash opvulling

Dit bericht delen

Terug naar overzicht